• Liebe Community,
    Aufgrund des niedrigen Traffics im Forum haben wir uns dazu entschlossen, es nur noch im Lesemodus zu betreiben. Neue Kommentare sind also nicht mehr möglich, wohl aber das Lesen der bestehenden Foreninhalte als Archiv. Ihr könnt diesen Account auch auf unseren anderen Portalen (pcgameshardware.de, pcgames.de, buffed.de etc.) nutzen oder Euren Account löschen lassen. Wir bitten um euer Verständnis und danken euch für die vielen tollen Beiträge.“

Probleme mit Mobile Hotspot

alexwaston

Neues Mitglied
Hallo liebe Android-Community,

ich habe ein Problem bzw. eine Frage zum Mobile Hotspot.
Ich arbeite derzeit an einem Versuch bzw. Projekt für die Uni, und zwar möchte ich mein Galaxy S7 als Mobilen Hotspot verwenden um dort einen Raspberry Pi 2 (der als WLAN Router eingestellt ist) zu verbinden und dann z.B. ein iPhone an den Raspberry Access Point zu koppeln, um die Datenpakete, die durch das iPhone abgerufen/gesendet werden zu loggen. Nun habe ich alles eingestellt, nur bekommt mein iPhone keine IP-Adresse zugewiesen.

Kann das sein, dass ich zwischen ein Gerät mit Mobilen Hotspot kein weiteren Router schalten darf, um das iPhone zu dort zu koppeln und mit dem iPhone ins Internet zu gehen?

Wäre echt super wenn ihr mir eine kurze Antwort darauf geben könntet und wenn es möglich ist, wie ich mein Problem lösen kann.

Vielen Dank schon einmal

Euer Gamer635
 
Zuletzt bearbeitet:

chief

Bekanntes Mitglied
Moin :)

Wie hast du das S7 als Hotspot eingerichtet? Per WLAN?

Kannst du das S7 nicht per USB als Hotspot einrichten? Dann greift der Rasperry per Kabel auf die Verbindung zu und teilt diese dann per WLAN, wo du dich dannit deinem iPhone einloggen kannst.
 

IchBinNichtAreamobile.de

Bekanntes Mitglied
Du brauchst keinen Router, sondern einen Repeater um das Internet ans iPhone über den RPi weitergeben zu können. Das Gute ist, dass OpenWRT das beherrscht, wenn ich mich recht erinnere. Dass das iPhone keine IP-Adresse (vom RPi, richtig?) bekommt liegt wohl an fehlenden oder falschen DHCP settings. Kann da nicht näher ins Detail gehen, wenn ich den genauen Fall nicht kenne.

Troubleshooting wäre erstmal auszuschließen, dass es etwas anderes als DHCP ist indem du die manuelle Zuweisung testweise erstmal probierst. Danach versuchen ein anderes Android- oder Windows-Gerät einzubinden per DHCP.

Achja ... noch gehe ich mal von IPv4 aus. Bei IPv6 hättest du das Problem ja normalerweise nicht :)
 
Oben